Topic

Staff Topic

[Testing is CLOSED, thank you!] Cosma wants YOU to help test stuff (and earn rewards)

UPDATE: Thanks for testing! We've gotten all the data we need for now and the test is officially closed!

---

Glitches of Ur:

Cosma is evaluating new features in the game engine and would like your help in testing them. And naturally, you will be rewarded.

Please DO NOT use your computer AT ALL while the tests are running!
Please DO NOT report bugs for weird things you see while testing. (They're just the way Cosma wants them.)

If you're ready to enlist, head here: www.glitch.com/perf/

If you're not yet sold on the idea... It won't take *any* effort to participate (you don't even have to be at your computer), but it will take 5-15 minutes for most people. You will be rewarded for testing up to three times. And if you have multiple computers or web browsers, Cosma would be grateful if you run a test on each.

Now that you're ready to enlist, head to www.glitch.com/perf/

---
If you encounter any problems during the test, try again.
If you still have trouble, you should stop testing, and Cosma thanks you for trying.

Posted 3 years ago by Jono Subscriber! | Permalink

Replies

  • did tests got stuck in the middle of the streets going left right left right in a loop till it times out don't know if that helped or not. but the places sure looked cool some of the grave stones where flashing was like disco of the dead lol.  
    Posted 3 years ago by satarell Subscriber! | Permalink
  • 64 Batterflies. Holy sh...er, guano.
    Posted 3 years ago by Otto Otto Subscriber! | Permalink
  • Ran three times on Firefox (latest version) on MacBook Pro using last version of Snow Leopard released before OS Lion...failed first and third times, passed the second...didn't touch the computer at all, just sat back and watched the fun...thought it was really neat just to get sneaky peeks at a couple places I've never been! Thanks, TS, for the bonus currant and xp reward!
    Posted 3 years ago by Abbey Rhode Subscriber! | Permalink
  • The Cat Face beat me to it but "The construct" me think of this...

    Stoot-eus: This is The Construct. It's our loading program. We can load anything from clothing, to equipment, piggies, training simulations, anything we need.

    Glitch-eo: Right now we're inside a computer program?

    Stoot-eus: Is it really so hard to believe? Your clothes are different. The plugs in your arms and head are gone. Your hair has changed. Your appearance now is what we call residual self image. It is the mental projection of your digital self.

    Glitch-eo: This...this isn't real?

    Stoot-eus: What is real? How do you define real? If you're talking about what you can feel, what you can smell, what you can taste and see, then real is simply electrical signals interpreted by your brain. This is the world that you know. The world as it was at the end of the twentieth century. It exists now only as part of a neural-interactive simulation that we call Ur. You've been living in a dream world, Glitch-eo. This is the world as it exists today... Welcome.. to the desert.. of the real.

    Also ran tests in win7-64bit on FF, Opera, and IE9(64), with no errors. Will do the same for Win8 and Ubuntu.
    Posted 3 years ago by hotmud Subscriber! | Permalink
  • I ran the test again on my laptop, since it's different from my desktop. No problems. =)
    Posted 3 years ago by Zany Serendipity Subscriber! | Permalink
  • Ran IE twice and Firefox once.  All successful but much slower on Firefox.  Using an Asus desktop and windows 7.
    Posted 3 years ago by Mostly Mellow Subscriber! | Permalink
  • so many batterflies
    Posted 3 years ago by Ida Keen Subscriber! | Permalink
  • neat-o! :)
    Posted 3 years ago by Kaybelikemaybe Subscriber! | Permalink
  • Test ran fine, though I practically had to sit on my hands to keep from clicking anything. Fun, fun! Cosma is one of my fave Giants, so anything for her...thanks for the rewards, too! FAFAFAFAFAFAFAFAFAFA...Talking Heads, anyone? That's a bit disturbing. ;)

    Edit: Test was on Chrome; will test later on IE and Firefox, rl work allowing.
    Posted 3 years ago by KitchWitch Subscriber! | Permalink
  • THIS IS ALL LIKE. BOSSERY !!! :D
    GLITCH ROCKSSSSS :D:D:D:D:D :P
    Posted 3 years ago by Apsd1109 Subscriber! | Permalink
  • I miss my fake friends. :(
    Posted 3 years ago by Silhouette Subscriber! | Permalink
  • SO MAD I CANT DO IT!!! stupid general Adobe Errors!  on a related note, anyone know how to get the adobe without it saying, General Errors, its kinda making me mad.
    Posted 3 years ago by Taco Assassin Subscriber! | Permalink
  • 3 successful attempts in a row.
    x2 on a custom built desktop PC using Firefox
    x1 on a Toshiba laptop using Chrome

    EDIT: both computers are running the 64bit version of Windows 7
    Posted 3 years ago by Xopher TAF Subscriber! | Permalink
  • Tested on Firefox/Vista on ye olde laptop, got one flash error null or soemthing, but then it ran fine. Will try Chrome next on ye olde laptop.
    Posted 3 years ago by Ayasta Subscriber! | Permalink
  • streets were a bit slow on firefox (vista) but chrome ran exactly the same on my ubuntu setup. i did try to get epiphany to play nicely, but it's apparently had a bit of a tiff with flash
    Posted 3 years ago by Myrtle Goodbody Subscriber! | Permalink
  • what is this?  just click on the link and go there?  I play glitch on ipad w iswifter browser sometimes.   Hope that doesn't break it.
    Posted 3 years ago by Treesa Subscriber! | Permalink
  • WinVista 64-bit on Chrome; first run without problems. Second run: connection timed out while testing in AF. The server reconnected, but my glitch was frozen. I re-loaded the page and it started the testing process again - ran through with no problem. 

    AF freaked me out. That many crabs in one place was a bit scary. =D
    Posted 3 years ago by Mnēmē Subscriber! | Permalink
  • The test was successful in Firefox and Chrome on Win7 64-bit.
    It wouldn't run in IE9 at first (on the same Win7 system), but after clearing browser cache, the test ran successfully.
    Posted 3 years ago by Varaeth Subscriber! | Permalink
  • Completely smooth test on 64 bit Windows 7, using Chrome :)
    Posted 3 years ago by Liza Throttlebottom Subscriber! | Permalink
  • Test on Opera, Chrome and Firefox done. Though it failed if the browser had more than a couple tabs open - I had to start new, empty sessions strictly for the tests. ;p
    Posted 3 years ago by Asthner Subscriber! | Permalink
  • Performance Testing
    Hmm, something went wrong during testing:
    Flash Error: null
    Perhaps you could try re-running the test?
    (IE9 on Windows)

    re-ran, happened again.
    third time not the charm. opening chrome...
    Chrome worked!
    Posted 3 years ago by diaveborn ♥ Subscriber! | Permalink
  • Awesome performance test! I'm curious to know what metrics you're watching. Judging from where the system slows, it looks like a test of heavy environental effects (e.g. steam/smoke/fog) active environment backgrounds (e.g. the lava falls), and scalability of on-screen NPCs, with "construct" thrown in as a baseline/cache reset?

    I'm sure you know this, but use of hardware acceleration is default to off/unchecked by Flash. Just in case your data collection doesn't contain that bit, I am running w/ hardware acceleration enabled.

    Oh, one more thing. Flash performance tends to dramatically slow when a browser window spans multiple monitors, even though the game window doesn't expand that far (oh how i wish it would). I'm assuming this is an edge case for the performance tests, so I'm keeping the browser window to just 1 monitor.
    Posted 3 years ago by CleverCharacterName Subscriber! | Permalink
  • Completed 2 tests (first one had to do again because it popped me out on the last test) using IE. Then went and played a while, exited and did 3rd test but it failed because I ran out of energy and died and then it had trouble finding me. So I squished and got out of hell, ate and drank some things to up my energy and was able to do the 3rd test. Thanks for the sneak peak at maybe some upcoming stuff.
    Posted 3 years ago by Gizmospooky Subscriber! | Permalink
  • Attempted to run the test on Safari but it wouldn't let me unless I upgraded to Flash 11. I have OSX 10.5, which is incompatible with Flash 11. (Edit: Same error with Firefox).
    Posted 3 years ago by Csophae Subscriber! | Permalink
  • A couple of the 5 tests timed out. The others worked (no failure notice). I used Internet Explorer 10 & Windows 8 Consumer Preview
    Posted 3 years ago by Treesa Subscriber! | Permalink
  • What's this got to do with Cosma? I reckon its Tii's territory...
    Posted 3 years ago by Treesa Subscriber! | Permalink
  • 2 of my 4 tests timed out. Just curious, did anyone else notice how the new Soulful and Soulless areas looked like beef jerky and nacho cheese??? :)
    Posted 3 years ago by litlc Subscriber! | Permalink
  • note- last night maybe , 1015pm EST , i started experiencing problesm with glitch and got kicked out of the world with error exclamation point screen - and gave up trying to get back in aftger a few attempts.. I have not today tried a regular game entry - just the entry that co-incides with attempting this test.

    1st test - on my desktop pc - i run windows xp , service pack 3 , IE explorer 7 .
    I have very outdated flash - as I am now paranoid to update it. Since the time when i did update it back in early november --and ended up being shut out of the game for a few days(so sad!) while you guys worked out whatever issue the flash update caused. My current flash is adobe flash player 11 active x , version 11.0.1.152
    the 1st test of 5 ran fine ( i think ) till near the end after I had walked back and forth a few passes- and then some sort of error happened (Sorry it went by SO fast i couldnt read it on themain screen - i think something abiout a file error) as shown by error message on main part of world screen .. also - in my messages of the the SIDE bar - it said god had trouble ..etc and said i was disconnect from server. HOwever - i seemed to move on to the rest of the tests automatically and completed all 5.
    ( i did see lot sof batterflies - but no guano on the ground , if that matters . )
    I will , in the interest of love for glitch , do a full restart on my pc - then update my flash (trembles at thought) and then will go back and test again . will post a second post with results. hope this helps ;)
    Posted 3 years ago by serenitycat Subscriber! | Permalink
  • Thanks for letting me help!!

    livestre.am/AWl2 < Watch the video I made.
    Posted 3 years ago by ToxicRainbowKisses Subscriber! | Permalink
  • I've tried for over 1 1/2 hours (two different sessions).  Two test complete in Soulful, NO tests complete in Animal Farm.  I keep getting "Ack! Something went wrong" and then the message "Flash Error: null".  I've tried three different browsers -- all the same result )FF. Chrome, IE).  When I go to The Construct it's just a blank white page. I guess no prize for me! :(
    Posted 3 years ago by Marla Subscriber! | Permalink
  • LOL @ b3achy!!!  

    All test smooth, ran perfect... both accounts twice each.

    Dell Desktop Win XP, Chrome, FF, and IE8

    Toshiba Laptop Win 7,  Chrome, FF, and IE8

    and.... on my iPad2....Photon Browser...ran perfect....Woot! 

    ETA:  
    Nerd of Epic gave me an idea...and same...didnt think it would work.....it went all the way to the first test screen...then Flash Error...lol

    Droid 4 Android Version 2.3.6  Flash Error: null  
    Posted 3 years ago by im4noles2 Subscriber! | Permalink
  • I don't know if it ran perfect, but I didn't get any failure messages with iswifter and the new ipad. There were only three tests this time.
    Posted 3 years ago by Treesa Subscriber! | Permalink
  • I've done the test half a dozen times or so and am wondering if continuing to run it is at all helpful for you guys now or if you have everything you need from my participation?
    Posted 3 years ago by Reni's Mum Subscriber! | Permalink
  • Tested:
    - Windows 7 Ultimate (64-bit) on a machine with crazy specs running Chrome, and then IE9.
    [Result:  (Chrome) Ran fine, took about 5 minutes.  (IE9) Crashed once, then ran fine on 2nd try.]
    - Ubuntu Linux 11.10 (32-bit) on a netbook with almost no specs at all running Chromium.
    [Result:  Ran really really slowly (~0.7 fps), but never crashed.  Took about 12 minutes.]
    - HTC Incredible 2 using default browser.
    [Result:  Flash Error: null.  But it did finish main loading screen and Soulless loading screens while trying to do the 1st test.]  (And no, I wasn't expecting this to actually work. :)
    Posted 3 years ago by Nerd of Epic Subscriber! | Permalink
  • <3

    testing was fun
    Posted 3 years ago by Clockwork Rabbit Subscriber! | Permalink
  • 2nd test- on my desktop pc - i run windows xp , service pack 3 , IE explorer 7 .
    adn just NOW ,prior to test did restart on PC , updated to flash player that says 11.2.202.233 then logged in to my glitch character (did not enter world) and entered world via forum page for test.
    2nd test reults. all seemed to run fine.
    when it said i had 3 test remaining i did notice guano from baterflies (did not see it 1st go round) . when it said i had 1 test remaining- i walked by the crabs but they did not greet me (if that matters) . thanks for letting me test-hope it helps ;)
    Posted 3 years ago by serenitycat Subscriber! | Permalink
  • saw 4  new things while testing, new vendor in soulful & the patch with: 'ready for.'.(something , cant remember what was written exactly), a floating baton on far right in animal kingdom and in very last on second testing saw a green/black crab!, 
    Posted 3 years ago by Jeasilver Subscriber! | Permalink
  • tests on IE and firefox complete each time tested but plug-in in Google Chrome always crashes only with the test as game runs fine.
    Posted 3 years ago by bee09 Subscriber! | Permalink
  • One set of tests run from my crappy wireless connection.  I'll try all 3 browsers again tomorrow on a different computer and a different ISP
    Posted 3 years ago by WindBorn Subscriber! | Permalink
  • Very impressive rates of spline reticulation!
    Posted 3 years ago by E D D I E Subscriber! | Permalink
  • Thanks for the Fun!  Loved all the Batterflies and the new NPCs!  I had a hard time not interacting so I sat on my hands.
    Posted 3 years ago by Brib Annie Subscriber! | Permalink
  • Toshiba laptop. Tests on Google Chrome, IE, Safari and Firefox. All of them correct.

    I saw 1 blue pig, some green crabs and a blue shiny rock. Plus something like a really interesting vendor, lol!
    Posted 3 years ago by Couso Subscriber! | Permalink
  • Loved the Vendor/Spice Tree Impersonator in Soulful and it took me everything I had not to click on the crabs, but I sat on my hands and got through it - actually, when I first read the post I thought the test was willpower.
    Ran it with Windows 7 on my laptop with no problems (though the Fa(il)(ke) Train in Animal Farm and Soulful was trippy). I'll try to run it on my home computer tomorrow. The poor thing is old and glitches in a non-Glitchy way, but if it works then I'll consider myself error free.
    Posted 3 years ago by Rue Bird Subscriber! | Permalink
  • Ran tests on my Desktop (windows xp) ... Chrome - no problems, IE - connection timed out, FF - 1st time got to final test & computer froze upon restarting whole computer, 2nd test no problems...

    Am about to go try on my (Dell) laptop, will come back and edit with updates on test runs, will be interesting since it hasn't been able to load pass map or house screens in over a week!

    EDIT: well test run on my Dell laptop (windows 7) - Chrome & FF no problems... IE - final test connection timed out... (now off to update my help case since apparently I can now load the game!)
    And also noticed mood & energy loss during testing...
    Posted 3 years ago by BumbleBeez Subscriber! | Permalink
  • Done on my gamer PC - 64bit, Win7, 8g RAM. Running on work laptop now - 64bit Win7, 4g RAM. Will run on my old Win XP laptop with 1g RAM next. 

    Hmm... will run in IE / Chrome / FF / Opera as well.
    Posted 3 years ago by Enelyse Subscriber! | Permalink
  • @Enelyse > Why are you running 32-bit windows 7 on a machine with 8gb of RAM? A gaming machine, no less. You do realize that 32-bit versions of windows can't use more than 3gb, right? I'm curious why you chose to nullify 5gb of your RAM with an improper version of windows 7.
    Posted 3 years ago by Lorraine ♪ Subscriber! | Permalink
  • I run the game on a 2010 i7 iMac, OSX Snow Leopard. I had no problem running the test on Chrome, Firefox or Safari! The only error I experienced was being disconnected from the game server once on Firefox and God intervened. The art looks really cool in those strange new places! :D
    Posted 3 years ago by Laerwen Subscriber! | Permalink
  • Ran successfully on Google Chrome, Windows 7, my Gateway laptop. <3 That was an awesome test! What is that floating tree dude!?
    Posted 3 years ago by BerylCrest Subscriber! | Permalink
  • I went and played the game for a while.  Had a Flash crash and decided to try the test again.  This time the test was successful on Firefox.  Using Vista 32 bit, 3 Gigs of RAM.
    Posted 3 years ago by Marla Subscriber! | Permalink
  • @Lorraine - Geez.  Typo after typo. LoL.  Long day. I think I've edited that post 4 times.  In fact I think 32 bit machines can't use more than 2g of RAM.
    Posted 3 years ago by Enelyse Subscriber! | Permalink