Topic

Installing the Flash debugger on Ubuntu (and more generally Debian)

Hello hello hello.

I had some difficulty getting the flash debugger working on Linux, but I finally got it. So here's a short tutorial for those of you who might be having trouble as well.

First of all, download the debug plugin here. Extract it to a convenient location.

The problem seems to be that flash tends to install crap all over the system, so you may have conflicting libraries. Here's what you do:

1. Uninstall flash. In the terminal, enter: sudo apt-get purge flashplugin-nonfree flashplugin-installer
2. then: sudo apt-get autoremove
3. Reinstall flash: sudo apt-get install flashplugin-nonfree
4. Now move the library you just downloaded to the location of the flash library. Example: sudo mv ~/flashplayer_10_plugin_debug/libflashplayer.so /usr/lib/flashplugin-installer/libflashplayer.so

This worked for me. Hopefully it helps. Do your part as a tester to ensure that Glitch runs as well on Linux as it does other OS's. GOD knows there aren't enough good Linux games out there.

Posted 3 years ago by Tofu Casserole Subscriber! | Permalink

Replies

  • Glad to hear you managed to get it running, thanks!
    Posted 3 years ago by Jono Subscriber! | Permalink
  • Tofu - was that 32-bit or 64-bit Ubuntu?

    I'm running 64-bit and find Flash a touch more fragile than it is on 32-bit... I'm wary of messing with it given that it works OK at the moment.
    Posted 3 years ago by Snazzlefrazz Subscriber! | Permalink
  • I too run 64-bit and also find flash just a little temperamental at times.

    Just the same as you Snazzlefrazz, am a little wary of playing with things when they seem to be working okay, I'd be very interested to find out :)
    Posted 3 years ago by Sayyadina Subscriber! | Permalink
  • I installed the debugger (manually) alongside the regular plugin on Linux Mint, I switch between them in about:plugins on Chrome when I play Glitch.
    Posted 3 years ago by Fussycat Subscriber! | Permalink
  • Thanks for this walkthrough.  Seems to have worked on my 64-bit system.
    Posted 3 years ago by martian-b Subscriber! | Permalink
  • I'm running Lucid on a 64-bit intel processor. Also, I didn't mention this before, but when you upgrade flash, you have to download the newest version of the debug player and replace the library again.
    Posted 3 years ago by Tofu Casserole Subscriber! | Permalink
  • good tutorial.  worked with no issues for me, 32-bit intel processor.  thanks!
    Posted 3 years ago by audiomodder Subscriber! | Permalink
  • Hi, has anyone running Firefox on Ubuntu made the Glitch greasemonkey scripts work? I could only get the automatic installs to work with Chromium. 
    Posted 3 years ago by rothko Subscriber! | Permalink