Topic

Background rendering problems in Safari/Retina display

This weekend I've seen some strange rendering in Ur streets (not my home street or house) that looks like some of the background and terrain images aren't being drawn. Sometimes they will come in when I walk across the street and sometimes not.

Screenshots: Nightshade Woods and Welldale.

Note that I'm playing on an Apple MacBook pro with Retina display using Safari. Flash version is 11.4.402.265.

Posted 7 years ago by Janitch Subscriber! | Permalink

Replies

  • Thanks Janitch; when this happens, could you please submit a report at that time, in the game with the bug icon?
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • Will do. If it helps, this doesn't happen when playing on an external monitor (only the built-in Retina display).
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • I'm seeing this too.  I've already filed a bug report.#next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; }
    Posted 7 years ago by smithco Subscriber! | Permalink
  • Good catch on the style; hopefully this will make it obvious. Otherwise, I will try to contact a staff member next time I'm in game.

    Or maybe Stoot will have to buy the staff new MacBook pros...
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • "Otherwise, I will try to contact a staff member next time I'm in game."

    Submitting a bug report is what we really would like; the staff in game (like myself) cannot dissect what the problem is, our client team needs to; they are watching this thread, but we need more errors from the game client. If you can reproduce it on purpose for us, we would appreciate it. Just make a new bug report, reference this thread and my post, submit it, and we'll get it in front of them.  :)
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • Done (just now).
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • I've discovered that the background rendering issue goes away for me with the new GPU option.  That may work for Janitch too.#next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; }
    Posted 7 years ago by smithco Subscriber! | Permalink
  • Do you still need more in-game bug reports on this? #next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; }
    Posted 7 years ago by dopiaza Subscriber! | Permalink
  • This is still a problem for me, and I ran into it on a home street as well today, so it's not just world streets (see how Vell's Street looks to me).
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • Now my home street has turned into a sulfur lake with small islands.
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • This one I call "imagining the chicken."
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • Just +1-ing. Filed a bug as well.
    Posted 7 years ago by Tim the Enchanter Subscriber! | Permalink
  • The stars are out in Ix.
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • :-(  The GPU renderer is disabled, so I can no longer work around this bug.#next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; }
    Posted 7 years ago by smithco Subscriber! | Permalink
  • Beautiful new scenery in Firozi?
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • Napping on transparent ridge.
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • Mysterious, yet bureaucratic-y, door.
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • This went away for a little while, but was back again tonight. Quit the game in the end - no point playing if I can't actually see where I am. Ho hum.#next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; }
    Posted 7 years ago by dopiaza Subscriber! | Permalink
  • Sorry, folks no updates on this one yet.
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • FWIW, this all seems fine in Chrome. I think I've only seen the problem in Safari.
    Posted 7 years ago by dopiaza Subscriber! | Permalink
  • I just discovered that zooming out (with the '-' button) all the way causes the background elements to reappear.  Since the game looks great zoomed out on a retina display, I don't mind using this workaround.
    Posted 7 years ago by smithco Subscriber! | Permalink
  • Oooh, nice find smithco.
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • I just started seeing this in Chrome on a Retina MBP last night.

    ETA: I tried the "zooming out" trick, and it works in Chrome as well. I don't have to zoom all the way out, just as many steps as it takes to restore all graphics. (I think it's two or three steps short of full zoom.)
    Posted 7 years ago by Pixley Subscriber! | Permalink
  • Yup, happens to me in Chrome too now. Zooming out does appear to work, but it makes everything significantly smaller and not particularly pleasant to play in. #next_pages_container { width: 5px; hight: 5px; position: absolute; top: -100px; left: -100px; z-index: 2147483647 !important; }
    Posted 7 years ago by dopiaza Subscriber! | Permalink
  • The newest regions are still not rendering properly (not that I have a lot of hope of it getting fixed at this point).
    Posted 6 years ago by Janitch Subscriber! | Permalink