Topic

Staff Topic

Flash Issues, Chrome and Firefox

Hello

This topic concerns issues with Flash on Chrome and Firefox, Windows. (See below for more about Chrome on Mac OS X)

Flash that is installed automatically on Chrome/Windows:

As we mentioned in this previous topic, you may see issues using Chrome in the game. Things like keyboard problems (you type something and some of the letters don't show), frame rates low, focus getting lost, etc. On Windows, this may be due to the Flash plugin which ships automatically with Chrome updates, the PPAPI version of the plugin. Note that Chrome updates itself, it is not a general user configurable preference to turn it off without some editing of special files. Also as mentioned, the easiest way to avoid this is to use another browser for the game.  

If you still want to use Chrome, try updating to the latest version of the browser by typing chrome://chrome/ in the address bar, then checking that page to see if you can update.  If that doesn't help, you can down the standalone plugin for other browsers here. 
 
Choose Windows, and then Flash 11 for 'other browsers', don't download the Internet Explorer version. Run the installer, then open Chrome and type chrome://plugins/ into the address bar.

Find the listing for "Flash," under which should be at two listings. The one on Windows which is not Chrome specific will have a name similar to: NPSWF32.DLL, or NPSWF32.DLL. Click *enable* on that version, and click *disable* any Flash version which is found in a subdirectory of Chrome. Unfortunately, when Chrome updates itself, it may change the settings back to what they were previously; so you may have to do this again.

Flash 11.4/Firefox on Windows:

Players have been reporting similar issues as described above with Firefox, and Flash 11.4. Some have reverted to earlier versions of Flash temporarily, but there something else you can try. It is a workaround outlined in this Adobe Community Flash post by one of the Flash developers, which indicates problems with Protected Mode; in some cases involving RealPlayer. The workaround may be difficult for many players who are not experienced with editing configuration files, or doing some heavy browser troubleshooting. In that case, you may want to just try an earlier version of Flash in the meantime. You can find instructions here on how to get an earlier plugin if you don't already have it on your computer.

Lastly, Chrome on Mac OS X:

Some players have problems with Chrome on Mac OS X. Things like chat lag and slow movements may be symptoms. If you are having those problems, we suggest using Firefox or Safari.

Posted 7 years ago by kevbob Subscriber! | Permalink

Replies

  • Thanks kevbob! Disabled all but the NPSWF32 and the game is running a LOT smoother! I love Chrome, and am now glad I can continue to Glitch with it!
    Posted 7 years ago by welshcorgi Subscriber! | Permalink
  • Since Chrome was identified as being a problem a few months ago, I've been running Glitch in Safari, while still using Chrome for normal browsing. It's actually nice having the game in a separate window from my web browser. For example, I'm cooking as I type this.
    Posted 7 years ago by Janitch Subscriber! | Permalink
  • Thanks, this chrome solution seems to have worked for me as well!
    Posted 7 years ago by Sir Cordray Subscriber! | Permalink
  • aah and i thought i just had too many windows opened and that's why it was going slow! ha will try Firefox next and see if its smoother .
    Posted 7 years ago by mav Subscriber! | Permalink
  • Kevbob, anything I can do on firefox/linux? Been experiencing weird jumps lately. 
    Posted 7 years ago by sudv ? Subscriber! | Permalink
  • In the last few days, I tried Chrome/Mac, Safari5/Mac, and finally landed on Firefox/Mac. Firefox is by far the most performant of these, Chrome is the worst (likely due to the sandboxing), Safari 5 is much worse than Safari 4, but still a little better than Chrome.
    Posted 7 years ago by Mattarr Subscriber! | Permalink
  • Ever since the game went down after zilloween my character jerks when I walk and I was wondering if this was a result of something thats being worked out or was i supposed to look for another solution? I use ie and always have with no problems.
    Posted 7 years ago by Soytoy Subscriber! | Permalink
  • Soytoy, different issue. Check this topic (but ignore the comments about zooming animals, it had nothing to do with the original post).
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • thanks for updating me :)
    Posted 7 years ago by Soytoy Subscriber! | Permalink
  • What a frustrating ordeal.  *sigh*

    The 11.4  update affected all three of my browsers; IE, Chrome, and Firefox.  
    After numerous trials and errors it seems (fingers crossed) the best fix for my browsers was to completely remove flash all together.  After uninstalling flash, I installed flash version 11.0.1.152; first installing the winax file (installs into IE), then installing the win_32bit file (installs into Chrome and FIrefox browsers). Then I enabled the NPSWF32.dll flash version in Chrome, and well, here I am ready to go to hell and STOMP on some grapes.
    Posted 7 years ago by jellybean4r2 Subscriber! | Permalink
  • Yup, I was still having the unpacking issue until later this evening 9-29. now I am getting a cannot load asset error on 3 different systems and 3 different versions of flash. :n(
    Posted 7 years ago by Baron Münchhausen Subscriber! | Permalink
  • Is there an update on what's being done to address this issue?  I've been unable to log in (unpacking and then asset error) since mid morning yesterday.  I've tried all the solutions suggested above but nothing so far has helped.
    Posted 7 years ago by Jinjur Subscriber! | Permalink
  • Jinjur- this topic is unrelated to the problem you are having logging in, as it happens. We are aware of your and the Baron's problems though and apologize for the issue; your (and the Baron's) help case(s) is where we'll follow up when we have some more information.
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • Thanks Kevbob!  
    Posted 7 years ago by Jinjur Subscriber! | Permalink
  • Chrome just isn't working out. Every time I have to reload, I have to find an earlier restore point on my computer, then re-update my Norton protection. Takes forever. Any ideas about which browser would work best with Windows 7? (I don't like IE, the only other browser I have on my computer.)
    Posted 7 years ago by Mollie Subscriber! | Permalink
  • @Mollie
    The other option right now is Firefox, but your problem sounds like something else is happening. I'm on Win7 using Chrome, and never have to do anything about restore point. Don't use Norton though, so not sure if it's something related to that.
    Posted 7 years ago by Elly Subscriber! | Permalink
  • Thanks for the response, Elly. This problem began only recently. Although the computer is relatively new, maybe 5 months, everything worked fine for several months. Only in the last couple of weeks has this other thing reared its head. It has me bumfuzzled. I am using IE for now, although I don't like it because it's difficult to control my avatar with IE. Maybe I will give Firefox a try. Thanks again.
    Posted 7 years ago by Mollie Subscriber! | Permalink
  • @MollieTry "Opera" - it's certainly not for everyone, but I've been really happy with it for many years. As an IT professional, I am required to advise anyone who comes near it, to regard IE as less of a browser and more of a vector. In short: avoid.
    Posted 7 years ago by Awful Horrid Subscriber! | Permalink
  • @Awful Horrid, IE has come a long way and I use it for glitch because I find it's how it runs best.  Now, I'm no "IT professional" or heart surgeon, but real life experience trumps your expertise which seems to be based on years ago experience or schooling.  Or something.   I'm not windows fangirl, love my two macpros but also use a windows gaming computer.
    Posted 7 years ago by Annettee Subscriber! | Permalink
  • @Kevbob, is there some where a person can submit a ticket?  A friend is having the same problem as Jinjur and she's beside herself.  D: 
    Posted 7 years ago by Annettee Subscriber! | Permalink
  • Annettee: She should look here first, and then here second, where a ticket can be submitted. (We have a 'Help' link at the top of the page, too.)
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • I am using chrome and very much want to avoid loading another browser, is there anything that is being done either by Glitch or Google to address the poor flash performance on chrome, or is it something we will all just have to learn to live with?
    Posted 7 years ago by WxFisch Subscriber! | Permalink
  • never EVER EVER randomly right click by mistake. i get a box i cannot get rid of and have to reload. arghh!!!
    Posted 7 years ago by Opally Subscriber! | Permalink
  • OMG reload is pretty much a daily message for me lately...I've done everything recommended here and tried Chrome, Firefox and (gulp) even IE. I'm not really keen on downloading any other browsers...I don't know; sucks to be me I guess! :'D any other tips?
    Posted 7 years ago by indimuse Subscriber! | Permalink
  • indimuse- checking some of the errors that are logged from your client when you are trying to get into the game, this looks like a connection issue unrelated to this thread. (I logged into the game as your player for a moment to be sure it wasn't anything tied to the player account, and it worked fine.) Please try our FAQ on loading problems, and then if needed, our connection test; and submit a help case from there which we can look at.
    Posted 7 years ago by kevbob Subscriber! | Permalink
  • I'd just like to share something that seems to help with keyboard input not working. Whenever I've had an issue with keyboard shortcuts not affecting the game, one of these two things always fixes it:
    - Flash doesn't have the focus, so clicking in the game window does it, or
    - it's acting as though the Control key is depressed, and typing that key solves the problem. I'm not sure why this happens so much, but I need to do it several times a day, depending how much I play. (It is just a Glitch thing; I don't have this issue at all elsewhere.)
    Posted 7 years ago by timothymh Subscriber! | Permalink