Topic

Glitch Companion 3.7

Features
-realtime mini map
-current street resource list
-travel bookmarks
-resources and snapshot tools
+keyboard shortcuts and quick slots

Original post (see updates below):
It all started with this idea.
I wanted quick shortcuts, so I decided to make a small script with Autohotkey.
It's a noob-like program language for non-devs like me :]
Then while I had that app running, I thought I totally could add additional tools and a nice GUI.
So I bundled other ideas from me or from the forums in three tabs, and a Glitch Companion.

It appears as an always-on-top widget, that you can move where you like over the game screen.
Here is how it fits in 1680x1050, you can probably place it over the chat in smaller resolutions.
This is a desktop app, and will not work with Mac os. It works with some limitations on Linux through Wine.
You can launch it from the source script if you feel paranoid and have Autohotkey 1.1+ installed,
or directly from the executable.
This is a standalone app, it's not for your browser
Requirements: Windows Xp or above or Linux with Wine

EDIT 2.0: New features
EDIT 2.1: Fixed keyboard for real
EDIT 3.0: Travel Book
EDIT 3.1: No worries release
EDIT 3.5: Snap 'em all
EDIT 3.6: Map updates
EDIT 3.7: New UI fixes

Download here : Glitch Companion 3.7 (1.1Mo)
Website HQ : Visit
Optional Greasemonkey launcher : Install
(For the launcher you need to have GM installed first and the app launched once, details)

Leave a comment and join the group !

Posted 3 years ago by Lemo Subscriber! | Permalink

Replies

Previous 1 2 3
  • Quick Guide

    Keyboard Shortcuts:
    When activated, each letter key on your keyboard (except WASD,B,F,L,M) will send [Enter], the Delay, and the letter key
    To squeeze a chicken for example just press Q. (see the underlined letter in item menus for all actions)
    Don't forget to disable them when entering the chat, or you may get some surprises!

    Ctrl+K : Enable/disable hotkeys
    Ctrl+E : Exit
    Ctrl+M : Map
    Ctrl+I : Infos
    Ctrl+Q : Quick slots
    Ctrl+T : Settings
    Ctrl+Tab : Switch between tabs
    Ctrl+Numpad1 : Minimap toggle street/terrain
    Ctrl+Numpad2 : Minimap trail
    Ctrl+Numpad3 : Minimap resources
    PageUp : Zoom out 0.2
    PageDown : Zoom in 0.2

    Screen1: live mini-map / GPS
    A 300x180 view of the area map, centered on your live position
    Thanks who everyone who helped on that thread!
    Use the 1,2,3 buttons to switch street, trail, and resource overlays
    The globe button will popup the full map

    Screen2: street resource list / detector
    With this one you don't have to read or even remember the loading screen
    The list will be available whenever you need it
    A little search box on the top can keep track of what you're looking for, and as you enter a street with
    that resource, a reminder will popup on the screen
    If you still can't find it, the search icon will launch a global search for you on Zog tools

    Screen3: travel book / street bookmarks
    Here you can save all your favorite, and most glitchiest streets you come to encounter in the worlds of Ur.
    The street preview come along with an assignable icon, and a notebook area for personal notes and details that you may want to remember about each place.
    Unlike the "teleport" menu, you get unlimited space for your needs.
    Each bookmark is accessible later to get you to destination.

    Screen4: links to API tools / notes / snapshot
    Various links to online tools for Glitch
    Some of them use directly your Profile Id, or the item you're looking for in the street tab
    And a notepad area to keep track of your current mood, business, listings...
    More info about the snapshot tools here

    Settings Panel:
    The timer is set to 10sec (10000msec) between each position check
    It should be perfectly fine already, as the loading screen is almost that long for each street
    Delay (200ms) is for the keyboard shortcuts, it's the time for the item-menu to load before you can select an action
    You may have to tweak this one slightly depending of your computer
    To edit the hotkeys you can have a look here for the complete listing
    The mask and line colors use Hex format with alpha, you can pick one color here
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Coming soon Resource mini map
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Awesome!  Is there a way to reassign the shortcuts?  I don't have a number pad on my laptop, which is what I use most often to play.

    Also, I can't get the map and street listing to work.  I'm using Chrome. Please forgive my ignorance, but I love this so far!  Help?
    Posted 3 years ago by Circe Subscriber! | Permalink
  • Thanks!
    Well I may do something later to change the hotkeys easily if you guys really need it :]
    That tab shorcut is very secondary though, I rarely use it
    In the meantime, if you install Autohotkey you can edit the script with Notepad, it's quite easy

    And yeah, again it's a desktop app for windows, it's not a browser thing sry
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Got it.  So the hotkeys are working wonderfully - I just can't get the listing of what's on each street to work...
    Posted 3 years ago by Circe Subscriber! | Permalink
  • Never mind, I figured out what I did wrong!  I put my user name instead of my profile ID.  That's working now.
    Posted 3 years ago by Circe Subscriber! | Permalink
  • Great :)
    I'll add details to the guide
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Which means you need to pet/ massage before nibbling/ milking a pig/butterfly..
    Posted 3 years ago by lalalakurasaki Subscriber! | Permalink
  • lrn2ak7
    Posted 3 years ago by Electric Wizard Subscriber! | Permalink
  • @lalalakurasaki Well you just have to press [n] to nibble or [k] to milk, what do you mean?

    @Rodríguez jrkfj1d3op o_O =) ?
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • I downloaded the app but I can't get it to work. When I right click on   Glitchcom 1.0.rar   it can't find a programme to open it :-S
    Posted 3 years ago by Anderella Subscriber! | Permalink
  • That's a compressed folder, just like zip
    Try Winrar or 7zip
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Wow, this is impressive!
    Posted 3 years ago by shipwreck Subscriber! | Permalink
  • glitchtastic! thx lemo. 
    Posted 3 years ago by dipity Subscriber! | Permalink
  • This looks awesome, but I'm a Mac guy, so can't use it sadly! 

    Good work though, love what people are making for Glitch. 
    Posted 3 years ago by Mr LaserExplosion Subscriber! | Permalink
  • Awesome idea.  I'd pay a few bucks for a Mac port! (And Mac has way easier builtins to automate this kind of thing, btw).  If only I had the time to do it myself...!
    Posted 3 years ago by Sprockett Subscriber! | Permalink
  • @Anderella I replaced the archive with a (slightly larger) zip one, probably easier now for everyone

    @Glitches
    Thx ! Actually I sorta had more fun doing this, than I had playing Glitch lately. It's just more interesting when you can create something. Hopefully that is about to change with the incoming house & design features and other stuff :]
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Congrats for the release!
    Posted 3 years ago by UXRoot Subscriber! | Permalink
  • AWESOME!!!!! Thank you thank you thank you!!!!! =)
    Posted 3 years ago by starrkittyface Subscriber! | Permalink
  • I mean this program changes all the alphabet keys to Enter as you stated and this means, press n for nibble won't work. you have to manually click up and then enter. Correct me if im wrong.
    Posted 3 years ago by lalalakurasaki Subscriber! | Permalink
  • Well I would rather use the enter key directly if that was the case :p
    It's just like I wrote above:
    "When activated, each letter key on your keyboard (except F,L,M) will send [Enter], the Delay, and the letter key"

    You know you can already use [n] for nibble after enter instead of the arrow keys, right?
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • You see, each letter key sends enter right? So now i meet a pig, i press N, commands come out (pet,nibble, etc.. ) I press N again, it will only works as an enter key, but not a N key.
    Posted 3 years ago by lalalakurasaki Subscriber! | Permalink
  • You see, each letter key sends enter right?
    Nope, it does "send [Enter], the Delay, and the letter key" -_-'
    Are you still talking in theory or did you actually tried the app with this result?
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • That mini-map looks amazing. Would def use if I had a PC
    Posted 3 years ago by Pomponella Subscriber! | Permalink
  • Lemo, did you cross-post the script to the AHK forms?

    And does it run with AutoHotkey-L ?

    [Long-time AHK monkey myself!!!]
    Posted 3 years ago by Sturminator IX Subscriber! | Permalink
  • I rarely post on those forums, I guess I'm just cutting out the technical discussion,
    and just sharing with the people that are actually gonna use it here :]
    But of course if you see any improvement (or idea) possible with the script, feel free to tell me about it!
    That's AHK-L indeed
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Lemo, that's an awesome app. However, there is one bug that annoys me. Basically, with this running, Caps Lock doesn't work! I've dabbled around with AHK, so I've determined the problem is that you're not detecting caps lock being on, so with caps on or off, it always sends the lowercase letter, since you're hotkeys being bound to each letter are always sending the lowercase. I'm not too good with AHK, so I couldn't figure out a solution (besides me just deleting the code that does the keys on/off, since I never use that. obviously though, that's not a proper fix). I tried doing a getKeyState, but that only detects when the key is being HELD, not when it's on. Though caps lock isn't used much, it's still something that some use occasionally. Not a HUGE bug, but if you're looking for something to fix, that could be good! :D

    EDIT: I made a fix! dl.dropbox.com/u/19510731/G... Now caps works properly, and I added a couple other things. First, if you do Control-R, it will re-download the Map file, in case of changes to the area. I also did a few graphics tweaks, for my liking. I've repackaged it, and you can take a look at the source in the .ahk. If you don't like my graphics tweaks, feel free to change them. If you want to incorporate any/all of my tweaks, I give you full permission too!
    Posted 3 years ago by Mocha Subscriber! | Permalink
  • it did send the enter, but it didn't send the letter.
    Posted 3 years ago by lalalakurasaki Subscriber! | Permalink
  • @Mocha Hey thx, I appreciate that kind of collaborative help!
    Not sure LOTS of people use caps lock to play Glitch (or maybe they use it for the chat, after deactivating the keys), but I guess it doesn't hurt to be all-terrain :]

    I'll have look later at reassignable shortcuts, and I'll add it at that time
    You probably noticed that this part of the code is quite annoying to edit for each key ;)
    Apparently it's possible to assign new shortcuts on the fly, see the first example down this page
    I'll try something more compact, with a loop and a hotkeys settings file

    The reload function is a good idea!
    Actually, with the upcoming "augmented" map, I plan to update it every time you launch the app to have the updated resources

    About the graphics, did you change anything else, beside the rounded corners?
    I updated the links in my first post, so people can have the choice easily

    @lalalakurasaki lol of course it didn't
    Still couldn't figure out if you're actually testing the app here, but if you have issues with the hotkeys/menu, you can try to set a higher delay, if the menu hasn't got the time to show up
    The [l]etter shortcut has no effect before the drop down menu is loaded
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Lemo - yeah, not many use caps, but as you said, it's good to get all the audiences! A hotkey settings file could be interesting. ;) I'm going to work on (soon) a couple ideas, then will post here.

    With graphics, it was just the rounded corners, and I changed the actual color of the window to #E6ECEE.
    Posted 3 years ago by Mocha Subscriber! | Permalink
  • I made more changes! dl.dropbox.com/u/19510731/G...

    So, you'll notice when you first open up the folder, there are less files now. The biggest benefit is that now it downloads the Map.ini on every run (I have it set to my Dropbox right now, but obviously, you can change it), and will download Settings.ini ONLY if it isn't there. The settings.ini downloaded now has a default player value of FILLME. When you first launch the companion (or any time the value is FILLME), it will ask you to put it in your ID, then it will write it to the ini, and restart. This makes it a bit easier for the less technically-inclined to get started with this ;)

    I made the map.ini download every time, since streets will change, and instead of having to release a new release every time there's a map update, you can just change the ini, upload it, and everyone will get the update.

    For the small stuff, there's now a loading splash when you first run (just so people know it's doing something when it's downloading the extra things), and there's no longer a Taskbar entry. (since it's always on top, we don't really need it. It's still in the little icons part of the taskbar though) And probably something else I've forgot... ;)
    Posted 3 years ago by Mocha Subscriber! | Permalink
  • Great ideas ^^
    I have uploaded Map.ini to the wiki, this way everyone can update it anytime ;)
    Here are the links to the page, and to the actual file to retrieve: Map.ini
    Not sure it's really necessary for the settings file though

    About the id, good one again, maybe we can add a button to open the profile there
    I wish there was a way to get it automatically
    Too bad URLDownloadToFile doesn't act as if you were logged in like with your actual browser

    I think the loading is a bit short to have a loading splash there, I'm just getting a blink of it even on my "ancient" computer. One thing to change though could be the (10s) timer, because I haven't found a way not to apply it first when the app start
    The taskbar removal also crossed my mind at some point, thx for thinking about it :]
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Yeah, we really don't need the settings.ini, I just kept messing mine up so much when testing, it was nice to quickly get a fresh start. xD Great idea to host on the wiki though, since then people can edit it together!

    I actually just got an idea for getting the ID automatically, and I will post here with a test soon. :D

    I also added the loading splash, since when I would test, though it really would just be there for a second, it's one of those things where it's nice to confirm to the user they launched it. I just sort of did it for the look.

    EDIT: Darn. For automatically getting the ID, I got as far as the point as getting my ID, but it would only get mine, since you have to implicitly specify a token, and each token only gets one person. Unless there's SOME way we could 1) open a page in a browser to ask for identity permissions 2) record the token somewhere that AHK could download it from 3) somehow get AHK to check that they've confirmed, and write it somewhere, we'd just have to ask the player to copy and paste their ID in manually.
    Posted 3 years ago by Mocha Subscriber! | Permalink
  • Yeah it didn't seem possible from my attempts either
    I think the more user friendly we can get is to ask for the user name in that first launch window
    Then go URLDownloadToFile, glitch.com/search/?q=%input% and grab the first result url
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • That would work, we'd just need to heavily filter the results, since there's a lot of HTML. I think regex could do that...
    Posted 3 years ago by Mocha Subscriber! | Permalink
  • *moving to stealth (aka email) mode*
    more updates coming soon
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • I was using Glitch Companion yesterday, very happy with how it was working, and really loving the hot keys, when I thought I would add a quick comment to global chat.  I have to admit that I am a terrible typist, and look at my keys when I type, so I didn't realize that I was creating a situation where only one keystroke was posting at a time, causing Global to scroll like crazy.  Once I saw what was happening, I immediately turned the hot keys off, and apologized to Global, and I haven't turned the hot keys back on since, but it was not enough to keep people from submitting a complaint about my "spamming" the chat.  It was not a happy feeling to get a finger-wagging in my email.

    The worst part to me was how quickly I must have been reported - there was only seconds between when I started having the typing problems and when I realized what was going on and apologized for doing it.  There must be some very enthusiastic complainers out there.

    Anyway, the moral to this story is: don't use the hot key feature if you like to chat. 
    Posted 3 years ago by Jewel Stoned Subscriber! | Permalink
  • Jewel - yikes, sorry about that. The reason that happens is because with keys on, it sends a fake enter key, then the letter you pressed. Maybe we should add a dialog when you turn on keys, to warn you not to chat. Again, super sorry! :(
    Posted 3 years ago by Mocha Subscriber! | Permalink
  • That makes perfect sense, really.  I thought it might be something like that.  I think installing a quick reminder about not chatting when you turn on the hot keys would be a great idea!
    Posted 3 years ago by Jewel Stoned Subscriber! | Permalink
  • Yeah sorry for that :\
    At some point I used the [tab] key to enable/disable the hotkeys, because it's the same that gets you to the chat panel in-game
    But that was kinda puzzling sometimes

    Anyway, the hotkey part is the most "fake" thing of this app, as Mocha said, and that's really something I'd like to see natively available in Glitch
    So don't forget to cast your vote over here if you like hotkeys
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • The new version of the Glitch Companion is now available for download
    Preview

    New features

    -Trail display and resource overlay (collaborative work with Janitch)
    Powered by Glitch Atlas, you now get a realtime view of the resources surrounding your current position. You can choose what kind of item you want to display to focus on specific resources.
    The "trail mode" records and displays on the map the path you traveled in that game session. It can help you to harvest more efficiently, or for completist achievements for example.

    -Customize everything! (starting from the request by Circe)
    I finally added a "user friendly" (but kinda crowded) settings panel. You can access it from the Glitchcom logo on the tools tab, and everything will be updated without having to reload the app.

    -First launch and graphical tweaks (ideas from Mocha)
    You're now asked for your user name, instead of the profile Id, with a lil avatar preview to check the result.
    The window feels more "borderless" and now integrates better on top of the game screen

    Minor updates
    -Full map (with the overlay goodies) available in a popup
    -Hotkeys will only work inside the game screen (when the "Game | Glitch" window is active)
    You can now type notes or google something without deactivating the keys
    I removed WASD from the shortcuts coz I remembered people actually may use that to move (hehe sry)
    -Housing streets and subway stations are now fine with the minimap

    I updated the download in the first post and the quick guide
    Go try it and tell me what you think (:
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • Runs - but not well - under WINE with Ubuntu Linux. It errors out a lot, maybe the buttons are trying to call other apps that aren't installed.

    A better explanation of how to use it wold be appreciated.
    Posted 3 years ago by Tsu Dho Nimh Subscriber! | Permalink
  • Ha! a comment thanks ^^
    I'm glad you did the test with Linux, I was sorta wondering if this could work
    Out of curiosity what part is working fine?

    I'm not calling any other app, but maybe that could be an issue with gdi+
    That's the graphical library present in Windows, I'm calling it to draw the maps
    I don't know if wine support that one well, you could try getting the gdiplus.dll on that page

    I did my best with the Quick Guide above in the second post,
    So if you have any specific howto question go ahead :]
    Hopefully there will be a greasemonkey version later for all browsers
    Posted 3 years ago by Lemo Subscriber! | Permalink
  • I would love to use this thing....but I can't type when it is loaded. It eats my letters no matter if the keys are turned on or off.
    Posted 2 years ago by phelps.mike Subscriber! | Permalink
  • Doesn't work on my Macbook Air.
    Posted 2 years ago by Bashere Subscriber! | Permalink
  • Thanks for the report mike
    Actually I had a few typing "gaps" sometimes as well, but I guess I needed users feedback to start thinking about fixing it ;)
    Does it eat "all" your letters, or just write something like "cmaponion" instead of "companion" from times to times?
    The 2.0 version used to launch the hotkey, then check if it should continue or just "type", and I think the problem happens when it tries to handle a hotkey and check the player position at the same time...

    Anyway :]
    I just find another way to deactivate those at the source, tell me if it's better now with:
    Glitch Companion 2.1
    (You can keep your 2.0 settings if you like and replace just Glitchcom.exe/.ahk)

    @Bashere Yup sorry it won't work with Mac Os or Linux as stated above :\
    Posted 2 years ago by Lemo Subscriber! | Permalink
  • MUCH better!!!! I think that did it!

     It was eating most of the letters...85-90% of them for me. But now it is great!
    Posted 2 years ago by phelps.mike Subscriber! | Permalink
  • (:
    Posted 2 years ago by Lemo Subscriber! | Permalink
  • Worked perfectly first time. Very impressive. Thanks so much for this.
    Posted 2 years ago by Puzz Subscriber! | Permalink
  • This is by far the best tool for Glitch I've ever seen. I can finally play with one hand! Thank you so much for sharing this with everyone.
    Posted 2 years ago by Sweet Stuff Ng Subscriber! | Permalink
Previous 1 2 3