Topic

Staff Topic

[Testing is CLOSED, thank you!] Cosma wants YOU to help test stuff (and earn rewards)

UPDATE: Thanks for testing! We've gotten all the data we need for now and the test is officially closed!

---

Glitches of Ur:

Cosma is evaluating new features in the game engine and would like your help in testing them. And naturally, you will be rewarded.

Please DO NOT use your computer AT ALL while the tests are running!
Please DO NOT report bugs for weird things you see while testing. (They're just the way Cosma wants them.)

If you're ready to enlist, head here: www.glitch.com/perf/

If you're not yet sold on the idea... It won't take *any* effort to participate (you don't even have to be at your computer), but it will take 5-15 minutes for most people. You will be rewarded for testing up to three times. And if you have multiple computers or web browsers, Cosma would be grateful if you run a test on each.

Now that you're ready to enlist, head to www.glitch.com/perf/

---
If you encounter any problems during the test, try again.
If you still have trouble, you should stop testing, and Cosma thanks you for trying.

Posted 2 years ago by Jono Subscriber! | Permalink

Replies

  • Win Vista (yay for old compu) + latest Firefox worked well after the slow initial loading. Animal farm didn't even stutter, although if those fakefriends had had textures, I think it would have, since the most lag I ever get ingame is in places with loads of other glitches.
    Posted 2 years ago by Souran Sweet Subscriber! | Permalink
  • @Enelyse: Pretty big typo! Yeah, in most cases, a single process cannot use more than 2gb in 32-bit environment. I not only run Windows 7 64-bit, but I also run Waterfox (64-bit firefox) with the 64-bit flash plugin. I ran the test as such.

    Sadly, the test on Animal Farm and Soulful ran 10x smoother than the real game does in my house. LOL. I'm on an i7 950 3ghz, 6gb ddr3 ram, and 1gb gtx 460 (tho vidcard doesn't matter with flash), and my house lags pretty bad regardless.
    Posted 2 years ago by Lorraine ♪ Subscriber! | Permalink
  • Had to run test twice. During the first test there was a forced disconnect and at least one phase of test reported as "Test Failed". May have been due to anti-virus update but I ewas AFK so can't be sure. Windows 7 home, Chrome 18.0.1025.162 m
    Posted 2 years ago by shadow_fire Subscriber! | Permalink
  • Ok I have tried to run the first test on Windows vista, IE and have been timed out twice, each time at the unpacking 100% are we suppose to click anything at all? Like the ok for the housing updates panel?, Gonna switch and try Firefox to see if theres a difference.

    Firefox ran the test beautifully with no problems at all, now I see how it should work i'll retry IE.

    Still had problems with IE, it tried to load soulful first and comnection timed out, as i moved to close the test it restarted and I got test completed, not sure how vaild the test is as i did touch the mousepad.

    Same result on the third trial on IE connection times out, if you then touch the mouse pad it will restart and continue the test.
    Posted 2 years ago by Faereluth Subscriber! | Permalink
  • Tried to run test using Idiot Explorer 9.0.8112.16421
    This required updating Adobe flash (NOTE to others: You must make IE default browser to update)
    Test failed to run, 1st time connection timed out after 100% unpacking, 2nd time after 100% splinar reticulation.
    Gave up.
    Posted 2 years ago by shadow_fire Subscriber! | Permalink
  • I tested on Windows 7, first on Chrome, second on IE, and third on Firefox.
    Chrome seemed overall faster, IE was slowest to run, and Firefox was slowest to load, although it was fast to run. Thanks for the rewards!!
    Posted 2 years ago by jjbob Subscriber! | Permalink
  • Something happened and my test failed after visiting animal farm. (windows, chrome).
    Will try at home later (mac, chrome, safari, firefox.)
    Posted 2 years ago by nekomaki Subscriber! | Permalink
  • Wow...I seem to be having the inverse of a lot of folks....
    Tested Chrome, Firefox, & IE....IE was fastest with the most crabs displaying "play me music" bubbles, Firefox was sluggish with 2 crab bubbles, and Chrome crashed to start, but ran fine on the second start and was a reasonable speed with no crab bubbles.  Not even sure what to make of that.  ;) 
    Posted 2 years ago by MiNu Subscriber! | Permalink
  • Completed five or six times no problems
    Posted 2 years ago by Naiad Subscriber! | Permalink
  • only reason im not doing a third test(yet): its taking too much time off my usual time to play glitch. 
    Posted 2 years ago by Kristabel Subscriber! | Permalink
  • I don't know if this will help anyone complete their tests...But after many failed attempts last night and one failed attempt this morning. I rebooted my internet and have now completed the test three times. :) 
    Posted 2 years ago by Cryztal Subscriber! | Permalink
  • 12 Galaxies?! Interesting...!
    Posted 2 years ago by sporks Subscriber! | Permalink
  • 2 test fails, null flash. 2 successful. All on Chrome. Only difference, I closed a few browser windows in between failing and succeeding.

    Should we be losing mood & energy during testing? I dropped from 1150 to 214 during 4 attempts. 
    Posted 2 years ago by Dagnabbit Rabbit Subscriber! | Permalink
  • I keep getting the null flash error on Opera (2 tries), but it worked first time on Chrome.
    Posted 2 years ago by Hana Firefly Subscriber! | Permalink
  • Got a "We need Flash!" screen- but I have Flash??
    Posted 2 years ago by Little Honey Subscriber! | Permalink
  • Little Same here, we need to get updated i guess...
    Posted 2 years ago by Taco Assassin Subscriber! | Permalink
  • Run test on my PC on which I run Internet Explorer, I used to have a lots of trouble playing glitch on Fire Fox. The test ran ok until the last test when my PC froze, I had to reboot. My PC then did a systems resore, not sure if I should try again. Then I tried on my laptop on which I run Chrome and finished the test. but when I tried to retest, it failed.
    Posted 2 years ago by Miss Melody Subscriber! | Permalink
  • "12 Galaxies?! Interesting...!"

    No to be a spoil sport or anything... but "12 Galaxies" (along with "mysterious vortex," "another castle"," etc) are just names the game puts in when you are traveling the a secret location as to not give spoilers to players. Same happens when you travel to many in game locations (some seam streets, etc).
    Posted 2 years ago by Lord Bacon-o Subscriber! | Permalink
  • this was fun :D
    tested on macbook pro, Snow leopard 10.6.8
    chrome = fine
    safari = fine
    firefox = fail 
    Posted 2 years ago by Ancale Subscriber! | Permalink
  • Hee this is delightful....i wish my real life software testing was this fun.
    Posted 2 years ago by FlatEarther Subscriber! | Permalink
  • Just had a fail on Chrome, Mac - test dropped out completely. It's possible my connection went haywire, but I couldn't tell if it was that or a hardcore browser crash.
    Posted 2 years ago by Cricket Subscriber! | Permalink
  •   Worked fine x3 with Firefox and Win 7.  Tried with Internet Explorer and Win 7.  Not once did I get a good load. It hung up every time during the loading screen for Soulful.
    Posted 2 years ago by Kaho Subscriber! | Permalink
  • Taco, I updated Flash and was able to run the test successfully three times!
    Posted 2 years ago by Little Honey Subscriber! | Permalink
  • Ran it on firefox, ie, and chrome...no diff that I saw (at least on screen).
    Posted 2 years ago by FlatEarther Subscriber! | Permalink
  • Happy to help. 
    That was rather heavier on my system than the regular game. I did notice "the construct" seemed to clear up a LOT of memory.
    Dunno if you have memory leak issues or just cache very aggressively, but it's not unusual to have the game eat up 800Mb-1.2Gb of RAM after a while, and busy chat windows seems to make it worse.
    Tested Chrome on OS X, will follow with Safari and Firefox.
    Posted 2 years ago by Zendragon  Subscriber! | Permalink
  • My froggy tried to deliver package during first test. I ignored it.
    During 2nd and 3rd test, a frog was in Soulful...justing hanging about. Did anyone else see it? And, in Animal farm I saw a pile of sparkly that had been mined around the stairs.
    Posted 2 years ago by bayBi Subscriber! | Permalink
  • I was a little hesitant because I read a lot of posts ahead of time, I'm cautious (ok, I'm chicken) and some people crashed, etc - but my session flew by effortlessly (in Chrome) and it only took about 5 minutes. Very cool. Hordes of batterflies and crabs - looked like a battercrab (crab-fly?) parade. Now I'm even more excited for the Glitch Renaissance! Thank you, Cosma, for the rewards, but I would have done this for free! :)
    Posted 2 years ago by Chetmo Subscriber! | Permalink
  • Ran perfectly in FF on Win 7

    I had to watch it through the Aero view, because otherwise I was too tempted to touch :)
    Posted 2 years ago by Rallie Subscriber! | Permalink
  • It crashed when I did it last night, partly because I refused to turn off Piece of Time, and partly because my computer is a POS. Worked mostly fine after that. I kept getting timeout errors when doing the 55 glitch train (trippy shiz) in Soulful.

    I must ask why Cosma is the one that wants the testing and not Tii. One would think that crunching endless streams of data would be his ish
    Posted 2 years ago by MarbhDamhsa Subscriber! | Permalink
  • Glitch on my macbook air almost came to a screaching halt but it made it through!
    Posted 2 years ago by Snowpuff Subscriber! | Permalink
  • Ran test on all my computers (Asus, HP Slimline, Gateway laptop & on my Ipad2 using Puffin.)  The only computer that ran 5 tests was my big gaming Asus computer - the others only ran 2 tests each using different browsers.  Puffin being ran on the Ipad2 was at the end of final test when it failed -  all other on "traditional" computers completed the tests.  Hope this was of some help.
    Posted 2 years ago by MzMunchken Subscriber! | Permalink
  • shame my gentoo box is having function issues (like, providing me with a screen). 

    Has anyone tried this with any form of linux box? granted flash is generally way behind, but it's always nice to see.

    also - drunken testing is the bananas.

    ETA: Airborne trees are a bit strange.
    Posted 2 years ago by arcturus Subscriber! | Permalink
  • @arcturus: I had to make sure my CPU didn't fall asleep in the middle of the test, so I moved my mouse, and when it hovered over the 'airborne tree' it said "street spirit"..... so it's a new version of the street spirits?
    Posted 2 years ago by RJStormRider Subscriber! | Permalink
  • if the purpose of this test was to really test my compulsiveness, then, I WON!  it was very hard not to click on things!
    Posted 2 years ago by little peep Subscriber! | Permalink
  • @Lorraine - ya should have seen the first typo when I claimed I had 64 MEG RAM and Win 7 Pro.  ROFL.  When I typo, I *really* typo.

    Your house lag could be ISP dependent? I know when Prime Time hits my area, my streaming movies stutter and performance goes down for MMOs but never really noticed it in Glitch as I don't play it as... well "intensively" as MMOs. Although I've made Flash crash a few times.
    Posted 2 years ago by Enelyse Subscriber! | Permalink
  • Aww, it doesn't like me!
    One of the tests crashes at the start -- I get a whole lovely list of flash errors.  Please tell Cosma to stop referencing null objects, it's bad form.  Variables want to be defined!
    Posted 2 years ago by Magic Monkey Subscriber! | Permalink
  • Everything runs just fine until it gets to Animal Farm. This is where all, or most,of the disconnects come, along with the message flash error: null and I start again. I have started many times and have yet to complete the test. I'm using windows 7 and chrome.
    Very frustrating, but very interesting new lands.
    Posted 2 years ago by Jo Jo Ruffledspouse Subscriber! | Permalink
  • again, disconnected in Animal farm. What gives with animal farm? It is very frustrating especially when I was on the last test. ARGH
    Posted 2 years ago by Jo Jo Ruffledspouse Subscriber! | Permalink
  • :( Awn, me too. Everything runs fine, but when it gets to Animal Farm and it had just just 1 test left, I get disconnected and a 'null' error happens. I wish so badly I could finish. I guess with the stream of fake friends + the quantity of animals and resources must crash my game? I'm not sure. :(
    Posted 2 years ago by Lila Clemenceau Subscriber! | Permalink
  • I think it's something with Chrome, actually, maybe along with Win 7 (or some other common element).  I've run it in IE (*shudder*) and Firefox with no issues, but I get the error with the "Aw, something went wrong :(" every time in Chrome.
    Posted 2 years ago by Magic Monkey Subscriber! | Permalink
  • Tested on 2 desktop PCs and a laptop.

    HP gaming desktop PC - failed all 20 times in lastest versions of IE, Firefox, Chrome and Safari and I have the latest version of flash. Best results in Safari of all the browsers!
    HP Laptop - failed every time in lastest versions of IE and Firefox with latest version of flash. Best results in IE9.
    Borrowed my mum's el cheapo crappy e pavillion desktop PC - was laggy but worked several times...every time in every browser! Best results in IE9.

    If I have learnt anything from testing, next time I am buying a computer I will just buy any old piece of crap...or maybe just an etch-a-sketch or scientific calculator that I can spell 58008 on and hold it upside down for my mates to giggle at cause it spells boobs. Never gets old.
    Posted 2 years ago by Cleops Subscriber! | Permalink
  • So. Many. Batterflies. *watches in amazement*

    Also, now I think I have an idea what paranoia must feel like...
    Posted 2 years ago by Lilleh Subscriber! | Permalink
  • I'm curious to know what kind of things client-side are being tested - on my relatively well powered iMac, it was mostly choppy and slow, yet on my old-and-therefore-sucky laptop, it was far smoother (both chrome, latest flash etc.). How come?
    Posted 2 years ago by Hburger Subscriber! | Permalink
  • I have (possibly) the slowest mobile broadband connection in the UK and had no problems in Chrome, but IE9 was sloooooow to unpack; both Chrome and IE ran well after loading. No errors, rather amazingly... All running on Windows 7, fairly good spec PC... I too am interested to know what is being tested specifically, and I too was hypnotised by so many batterflies o_0
    Posted 2 years ago by Ama Gad Subscriber! | Permalink
  • I'm running Firefox on an old junker E-Machine, with Linux Ubuntu 11.04..... It's okay, for an E-Machine....
    Posted 2 years ago by RJStormRider Subscriber! | Permalink
  • For the record, I only use Chrome
    Posted 2 years ago by MarbhDamhsa Subscriber! | Permalink
  • Maybe what's being tested is our willingness to blindly submit ourselves to being tested.
    Posted 2 years ago by Sirentist Subscriber! | Permalink
  • All those crabs made me itch...
    Posted 2 years ago by bergamot Subscriber! | Permalink
  • Not sure if flash is failing me, or it's my ISP causing me to be "temporarily disconnected."

    Here's the info:
    Hmm, something went wrong during testing:

    Flash Error: Error: Bad type in socket at com.tinyspeck.engine.business::NetDelegateSocket/getAndParseIncomingMessage()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/business/NetDelegateSocket.as:303] at com.tinyspeck.engine.business::NetDelegateSocket/checkIncomingData()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/business/NetDelegateSocket.as:262] at com.tinyspeck.engine.business::NetDelegateSocket/onSocketData()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/business/NetDelegateSocket.as:234]
    Posted 2 years ago by Cleric Wens Subscriber! | Permalink
  • Or maybe my theory is shot since it's crashing in FF for me now.  For fun, here's the whole of the error that I get:
     
    Flash Error: TypeError: Error #1009: Cannot access a property or method of a null object reference. at starling.core::RenderSupport()[C:\work\actionscript\Starling-Framework_TS\starling\src\starling\core\RenderSupport.as:63] at com.tinyspeck.engine.view.renderer.commands::DrawLocationViewToBMDCmd()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/renderer/commands/DrawLocationViewToBMDCmd.as:20] at com.tinyspeck.engine.view.renderer.commands::LocationCommands$/drawLocationViewToBMDCmd()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/renderer/commands/LocationCommands.as:74] at com.tinyspeck.engine.view.renderer::LocationRenderer/getSnapshot()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/renderer/LocationRenderer.as:838] at com.tinyspeck.engine.control::TSFrontController/resnapMiniMap()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/control/TSFrontController.as:3910] at com.tinyspeck.engine.view.renderer::LocationRenderer/render()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/renderer/LocationRenderer.as:1140] at com.tinyspeck.engine.view.renderer::LocationRenderer/scrollAndRender()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/renderer/LocationRenderer.as:288] at com.tinyspeck.engine.view.renderer::LocationRenderer/onGameLoop()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/renderer/LocationRenderer.as:220] at com.tinyspeck.engine.view::TSMainView/gameLoop()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/view/TSMainView.as:1052] at com.tinyspeck.engine.control.engine::ViewController/gameLoop()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/control/engine/ViewController.as:135] at com.tinyspeck.engine.control::MainEngineController/gameLoop()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/engine/control/MainEngineController.as:219] at com.tinyspeck.core.beacon::StageBeacon/onEnterFrame()[/Volumes/TinySpeck/clean/clientNew/src/com/tinyspeck/core/beacon/StageBeacon.as:103]
    Posted 2 years ago by Magic Monkey Subscriber! | Permalink